michaeljohnbarr / django-timezone-utils : #49
Showing trends for 23 Dec 2017 to 22 Jan 2018

Overview

100% Excellent!

In The Last 30 Days:

No changes

Overall Health

No changes

Code Errors

No changes

Code Smells

No changes

Style Warnings

Recent Activity

100% master #49

31 Oct 2016, 4:37 a.m. michaeljohnbarr 9954f47 (master)

Official version 0.11 bump

100% master #48

31 Oct 2016, 3:53 a.m. web-flow ad65d30 (master)

Drop django 1.4 to 1.7 support (#8)

- Removed reference to django.db.models.fields.subclassing.SubfieldBase (resolves #7) and conditional import for `django.core.checks`.
- Removed the `timezone_utils/models.py` and `timezone_utils/migrations`. This means that only Django 1.8+ is now supported.
- Removed support for Python versions < 2.6. The Django 1.6 series was the last to support Python 2.6.
- Added testing support for Django 1.10.
- Coverage fix: calling the super(DateTimeField, self).to_python(value) will convert a naive datetime, so the is_naive condition would never be reached.
- Changed development status from `Beta` to `Production/Stable`.
- Added contributor Alex Kamedov.
- Updated documentation copyright year to 2016.
- Version bump to `0.11`.
- Minor PEP8 changes.

100% drop-django-1.4-to-1.7-support #47

29 Oct 2016, 9:47 p.m. michaeljohnbarr e70f8ba (drop-django-1.4-to-1.7-support)

Updated README

Removed the note that the development status is BETA.

100% drop-django-1.4-to-1.7-support #46

29 Oct 2016, 7:12 p.m. michaeljohnbarr 80e1d69 (drop-django-1.4-to-1.7-support)

Added contributor / Updated Copyright year

100% drop-django-1.4-to-1.7-support #45

29 Oct 2016, 6:53 p.m. michaeljohnbarr e41d075 (drop-django-1.4-to-1.7-support)

Coverage fix.

Calling the super(DateTimeField, self).to_python(value) will convert a naive datetime, so the is_naive condition would never be reached.

100% drop-django-1.4-to-1.7-support #44

29 Oct 2016, 6:37 p.m. michaeljohnbarr 1965e40 (drop-django-1.4-to-1.7-support)

Travis CI Django Master fix

Exclude Python 3.2/3.3 from Django's master branch In Travis CI.

100% drop-django-1.4-to-1.7-support #43

29 Oct 2016, 6:18 p.m. michaeljohnbarr dc1d203 (drop-django-1.4-to-1.7-support)

Travis CI Fix

Used the = instead of the - sign for setting the Travis CI Django version for 1.10.

100% drop-django-1.4-to-1.7-support #42

29 Oct 2016, 6:15 p.m. michaeljohnbarr 4f1dd21 (drop-django-1.4-to-1.7-support)

Travis CI Fix Attempt

Remove .0 from Django versions...e.g. 1.9.0, 1.10.0

100% drop-django-1.4-to-1.7-support #41

29 Oct 2016, 6:07 p.m. michaeljohnbarr 7618b33 (drop-django-1.4-to-1.7-support)

Drop support for Django < 1.8

Added Django >= 1.8 as a requirement to the setup.

100% drop-django-1.4-to-1.7-support #40

29 Oct 2016, 5:56 p.m. michaeljohnbarr 7a87cee (drop-django-1.4-to-1.7-support)

Drop support of Django < 1.8

Removed reference to django.db.models.fields.subclassing.SubfieldBase and conditional import for django.core.checks. Also removed the timezone_utils/models.py and timezone_utils/migrations. This means that only Django 1.8+ is now supported.

Removed support for Python versions < 2.6. The Django 1.6 series was the last to support Python 2.6.

Added testing support for Django 1.10.

Changed development status from Beta to Production/Stable.

Minor PEP8 changes.